Right blinker not working - FirebirdV6.com/CamaroV6.com Message Board

Announcement

Collapse
No announcement yet.

Right blinker not working

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Right blinker not working

    I have been to a mechanic twice now and my right blinker worked for a while and then stopped working. I haven't had time to look at it yet. Does anyone have step by step instructions on how to repair my right blinker? What parts would I need? A while ago I believe my spare tire and jack were causing issues with wires. Maybe that has somthing to do with this?

  • #2
    What year camaro do you have? Is it a coupe? Need more info on it. Doubt its your spare tire or jack your wires dont run any where near them.
    08' L76 6.0L 4X4 Chevy EXT.Cab LTZ Vortec MAX with Snug top cover, Dynomax exhaust,Hptuners& K&N intake
    96' Camaro M5 to A4 conversion, alot of mods ,see Homepage. GT35R Turbo http://www.cardomain.com/ride/244123...vrolet-camaro/

    Comment


    • #3
      I kept blowing front blinker bulbs ('97 RS) a while back and ended up replacing the flasher unit and I haven't blown a bulb since. Worth a try?

      Comment


      • #4
        So the flasher unit fixed it?
        08' L76 6.0L 4X4 Chevy EXT.Cab LTZ Vortec MAX with Snug top cover, Dynomax exhaust,Hptuners& K&N intake
        96' Camaro M5 to A4 conversion, alot of mods ,see Homepage. GT35R Turbo http://www.cardomain.com/ride/244123...vrolet-camaro/

        Comment


        • #5
          It did for me. I went with an electronic flasher vice the original GM.

          Comment


          • #6
            Since he brought up his tire and jack I assuming its in the rear, ill wait and see if he posts up a year and model.
            08' L76 6.0L 4X4 Chevy EXT.Cab LTZ Vortec MAX with Snug top cover, Dynomax exhaust,Hptuners& K&N intake
            96' Camaro M5 to A4 conversion, alot of mods ,see Homepage. GT35R Turbo http://www.cardomain.com/ride/244123...vrolet-camaro/

            Comment


            • #7
              2002 Camaro with t-tops. A while back when I changed my flat I suppose I didn't put the spare tire and Jack away securely, because since then it's rattled a lot. and the mechanic I went to said somthing about the spare tire/Jack damaging wires when my one of my tail lights were out.

              Comment


              • #8
                My flasher unit being replaced sounds familiar. It's been problem after problem with front and back lights going out. My right blinker was working twice now, then after a while stops. I used to have to manually push my right signal every time I turned right. Now I can't manually signal right anymore because it stopped working
                Last edited by Camaro3800v6; 05-21-2018, 11:10 PM.

                Comment


                • #9
                  I would see if you have power to it with a mutimeter.
                  08' L76 6.0L 4X4 Chevy EXT.Cab LTZ Vortec MAX with Snug top cover, Dynomax exhaust,Hptuners& K&N intake
                  96' Camaro M5 to A4 conversion, alot of mods ,see Homepage. GT35R Turbo http://www.cardomain.com/ride/244123...vrolet-camaro/

                  Comment


                  • #10
                    Originally posted by Camaro3800v6 View Post
                    My flasher unit being replaced sounds familiar. It's been problem after problem with front and back lights going out. My right blinker was working twice now, then after a while stops. I used to have to manually push my right signal every time I turned right. Now I can't manually signal right anymore because it stopped working
                    What do you mean you had to manually push your right signal every time you turned right? Do you mean the signal arm on the steering column isn't staying in place?

                    If your mechanic mentioned your spare tire and jack rattling around, have you looked at the wiring back there in the wheel well for any cuts / shorts? Pull the electrical tape off of the wiring going to your tail lights and inspect all of that wiring for any bare wires / breaks.

                    When the lights go out are you blowing a fuse? or is the bulb going out? And when it happens is it both front and rear blinker lights or is it just the rear lights? The bulb could be loose in the housing in the tail lights, or corrosion in the socket could be preventing a good connection

                    2002 SOM Z28 Camaro
                    1996 3800 camaro- Gone - still the fastest N/A Canadian 3.8L F-body
                    V6 best: 13.43 @ 100.77 mph


                    My Current Build | Synthetic Oil | Videos

                    Comment


                    • #11
                      When I push my right blinker it won't continually click, but it will sometimes light up in the back so I keep pushing my blinker lever when I make a right turn. My left blinker works just fine.

                      I will have to go check the wiring. I think the fuse has been ok each time this happend. At the moment right now it's just the front right bulb not flashing. Only the back right signal will light up when I push the right turn signal but won't automatically flash.

                      I checked all my lights and every light is on. My right turn signal doesn't make a clicking sound or flash. But my right yellow light is on and looks bright.
                      Last edited by Camaro3800v6; 05-26-2018, 06:01 AM.

                      Comment


                      • #12
                        I was planning on buying a multimeter when I had more time, but I just read this.

                        The Haynes manual says " the turn signal flasher, a small canister shaped unit located under the dash, in a clip to the left of the steering column, flashes the turn signals.

                        When the flasher unit is functioning properly, an audible click can be heard during its operation. If the turn signals fail on one side or the other and the flasher unit does not make its characteristic clicking sound, a faulty turn signal bulb is indicated.

                        If both turn signals fail to blink, the problem may be due to a blown fuse, a faulty flasher unit, a broken switch or a loose or open connection."
                        Last edited by Camaro3800v6; 05-26-2018, 05:46 PM.

                        Comment


                        • #13
                          so my right yellow light is fully on and even looks bright, so I don't think it's a faulty turn signal bulb?

                          Comment


                          • #14
                            Have you replaced the flasher unit? Did it solve the problem?

                            2002 SOM Z28 Camaro
                            1996 3800 camaro- Gone - still the fastest N/A Canadian 3.8L F-body
                            V6 best: 13.43 @ 100.77 mph


                            My Current Build | Synthetic Oil | Videos

                            Comment


                            • #15
                              I think one of the times I've been to the mechanic they did replace the flasher unit. since my signal did work for a while, then broke again maybe the flasher unit they put in was junk. If I get time today I will check all the wiring.

                              Comment

                              Latest Topics

                              Collapse

                              • ssms5411
                                Po300 random misfire is back
                                ssms5411
                                Like title says random misfire is back, hard to start also, have to give it gas when cranking it over to start for about 2 years now, thought it was something...
                                1 day ago
                              • 2.8 Bird
                                Walbro 255?
                                2.8 Bird
                                So I was about to purchase this from ebay and the seller told me it won't work for my 98 v6 firebird.

                                He said it's only for v8. I thought...
                                1 week ago
                              • ssms5411
                                Dtc 341 cam sensor
                                ssms5411
                                So last few times Ive started and let the Camaro run for 20min. I ve got a dtc 341 cam sensor, replaced the sensor about a couple of months ago, when...
                                1 week ago
                              • ssms5411
                                Found a good used console
                                ssms5411
                                Got one off ebay, mines cracked in a few places . And of course the lid is broken off, all the used ones off ebay had them all broken off. Also got some...
                                2 weeks ago
                              • Phillpatton18
                                Exhaust manifold bolts
                                Phillpatton18
                                Having trouble with the passenger side exhaust manifold bolts. Any advice to make the job easier. Been a pain in the ass...
                                2 weeks ago

                              FORUM SPONSORS

                              Collapse
                              Working...
                              X