96 won't Start.Battery good, ding from key trying to start,couple clicks then nothing - FirebirdV6.com/CamaroV6.com Message Board

Announcement

Collapse
No announcement yet.

96 won't Start.Battery good, ding from key trying to start,couple clicks then nothing

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • 96 won't Start.Battery good, ding from key trying to start,couple clicks then nothing

    OK, so drove home fine no issues. Went to start next day and normal ding ding from key in the ignition then try to start and just get a couple clicks then nothing. even the dome light goes out. I figure there must be a breaker somewhere that is tripping because after waiting 15 to 20 minutes I can do the same thing all over again. I've checked the battery and its holding 12.6 volts. Even with a jump it still does the same. If anyone has any ideas for what to check next, it will be greatly appreciated. Thanks

  • #2
    Is it throwing in security lights? Could be the key,vats problem try a spare. Does the fuel pump prime up when you turn the key? How old is the starter? Just throwing stuff out there.
    08' L76 6.0L 4X4 Chevy EXT.Cab LTZ Vortec MAX with Snug top cover, Dynomax exhaust,Hptuners& K&N intake
    96' Camaro M5 to A4 conversion, alot of mods ,see Homepage. GT35R Turbo https://www.facebook.com/steve.starcher.18

    Comment


    • #3
      Originally posted by ssms5411 View Post
      Is it throwing in security lights? Could be the key,vats problem try a spare. Does the fuel pump prime up when you turn the key? How old is the starter? Just throwing stuff out there.
      Thanks for the suggestions. No security lights thrown. It does the same with both keys we have. Bought the car 10 or 11 years ago, haven't had any starter issues. I will check and see if I can hear the fuel pump. Just didn't know if there was a master breaker somewhere since all power goes out after trying to start. Don't here the fuel pump priming, will that kill all electrics ?
      Last edited by gatormike69; 03-30-2022, 06:43 PM.

      Comment


      • #4
        Try checking your starter and starter wire to the battery.
        08' L76 6.0L 4X4 Chevy EXT.Cab LTZ Vortec MAX with Snug top cover, Dynomax exhaust,Hptuners& K&N intake
        96' Camaro M5 to A4 conversion, alot of mods ,see Homepage. GT35R Turbo https://www.facebook.com/steve.starcher.18

        Comment


        • #5
          If all the wires and grounds are good, could be a BCM issue. https://highperformancejunkies.com/h...dy-bcm-repair/

          2002 SOM Z28 Camaro - 12.9 @ 104 mph
          1996 3800 Camaro - 13.43 @ 100.77 mph


          Project Cars | How To Guides | Scratch Repair | Synthetic Oil

          Comment

          Latest Topics

          Collapse

          FORUM SPONSORS

          Collapse
          Working...
          X